Eltex логотипЕсли ваша задача  создать высокопроизводительную и высокоскоростную беспроводную сеть в местах большого скопления людей, таких как конференц-залы, гостиницы, выставки, то оборудование российского производителя Eltex подойдет вам как нельзя лучше. Благодаря поддержке стандартов IEEE 802.11n/ac точки доступа обеспечивают скорость передачи данных 1300 Мбит/с (5 ГГц) + 450 Мбит/с (2.4 ГГц). Для стабильной и непрерывной работы устройства используются высокопроизводительные процессоры Broadcom, позволяющие добиться самых высоких показателей в скорости обработки данных. Точки доступа поддерживают питание через PoE и способны работать в кластере без выделенного сервера (до 64 устройств).

Для того чтобы развернуть хотспот с портальной авторизацией, вы можете использовать программное обеспечение производителя SoftWLC, устанавливаемое на ваш сервер, или использовать наш облачный сервис с помощью контроллеров хотспота на базе роутеров MikroTik или установки нашего Linux контроллера на сервер (возможно установка на сервер с SoftWLC).

В данной статье мы рассмотрим, как развернуть гостевую и рабочую сеть с помощью  точек доступа Eltex WEP-2ac и роутера Mikrotik в качестве контроллера хотспота.

Для начала подготовим конфигурацию на микротике. Настраивать микротик необходимо, подключившись ко 2 порту. Иначе при вставке конфига настройка может прерваться.

Внимание! Обязательно замените все вложения NASID в конфиге на nas id вашего хотспота из личного кабинета!

В данном конфиге мы настраиваем 3 сети:
1) сеть управления 192.168.100.0/22
Она нужна для управления точками доступа и другого оборудования, которое будет подключено к микротику.

2) гостевая сеть 10.20.0.0/22
Открытая сеть с авторизацией для доступа к интернету. Настроена на VLAN10

3) рабочая сеть 192.168.200.0/22
Закрытая рабочая сеть с паролем. Настроена на VLAN50

/ip dhcp-client add interface=ether1 disabled=no
/ip dns set allow-remote-requests=yes servers=8.8.8.8,208.67.222.222
/interface bridge add name=inet-bridge
/interface vlan add interface=inet-bridge name=vlan10 vlan-id=10
/interface vlan add interface=inet-bridge name=vlan50 vlan-id=50
/ip hotspot profile add hotspot-address=10.20.0.1 name=wfspot1
/ip pool add name=hs-pool-1 ranges=10.20.0.2-10.20.3.253
/ip dhcp-server add address-pool=hs-pool-1 disabled=no interface=vlan10 lease-time=16h name=hs-dhcp 
/ip hotspot add address-pool=hs-pool-1 disabled=no interface=vlan10 name=NASID profile=wfspot1
/interface bridge port add bridge=inet-bridge interface=wlan1
/interface bridge port add bridge=inet-bridge interface=ether3
/interface bridge port add bridge=inet-bridge interface=ether4
/interface bridge port add bridge=inet-bridge interface=ether5
/ip address add address=10.20.0.1/22 comment="HotSpot network" interface=vlan10 network=10.20.0.0
/ip dhcp-server network add address=10.20.0.0/22 comment="HotSpot network" dns-server=8.8.8.8,208.67.222.222 gateway=10.20.0.1 netmask=22
/ip firewall nat add action=masquerade chain=srcnat comment="masquerade HotSpot network" src-address=10.20.0.0/22
/ip hotspot user add name=admin
/ip hotspot profile set wfspot1 use-radius=yes
/ip hotspot profile set wfspot1 login-by=http-pap,http-chap,https
/radius add service=hotspot address=195.14.118.42 secret=wfs123 timeout=3000ms
/radius add service=hotspot address=95.167.165.93 secret=wfs123 timeout=3000ms
/ip hotspot walled-garden add dst-host=*.wifisystem.ru
/ip hotspot walled-garden add dst-host=*.paymaster.ru
/ip hotspot walled-garden add dst-host=mc.yandex.ru
/ip hotspot walled-garden add dst-host=esia.gosuslugi.ru
/ip hotspot walled-garden ip add dst-address=95.167.165.64/27
/ip hotspot walled-garden ip add dst-address=195.14.118.0/23
/ip hotspot walled-garden ip add dst-address=91.229.116.0/22
/ip hotspot walled-garden ip add dst-address=213.59.200.64/28
/ip hotspot walled-garden ip add dst-address=91.200.28.0/24
/ip hotspot walled-garden ip add dst-address=91.227.52.0/24
/ip hotspot walled-garden ip add dst-address=109.207.2.0/24
/ip hotspot walled-garden ip add dst-address=10.0.0.0/8
/ip hotspot walled-garden ip add dst-address=172.16.0.0/12
/ip hotspot walled-garden ip add dst-address=192.168.0.0/16
/system clock set time-zone-autodetect=no time-zone-name=manual
/system clock manual set time-zone=gmt dst-delta=+03:00
/system ntp client set enabled=yes server-dns-names=pool.ntp.org
:if ([:len [/file find name=flash]] > 0) do={/system scheduler add interval=15m name=service on-event="import file-name=/flash/hsfailover" policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive start-date=jan/01/1970 start-time=01:30:33} else={/system scheduler add interval=15m name=service on-event="import file-name=hsfailover" policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive start-date=jan/01/1970 start-time=01:30:33}
/system scheduler add interval=15m name=up on-event="/tool fetch keep-result=no url=(\"http://auth.wifisystem.ru/status/\?mac=\".[/interface ethernet get 0 mac-address].\"&nasid=\".[/system identity get name].\"&os=mikrotik&load=\".[/system clock get time].\"%20up%20\".[/system resource get uptime].\",%20load%20average:%20\".[/system resource get cpu-load].\"&soft=\".[/system package get system version])" policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive start-date=jan/01/1970 start-time=01:30:03
/ip hotspot user profile set default keepalive-timeout=16h shared-users=5
/system identity set name=NASID
/ip pool add name=inet-pool ranges=192.168.100.2-192.168.103.253
/ip dhcp-server add address-pool=inet-pool disabled=no interface=inet-bridge lease-time=16h name=inet-dhcp
/ip address add address=192.168.100.1/22 comment="Internet network" interface=inet-bridge network=192.168.100.0
/ip dhcp-server network add address=192.168.100.0/22 comment="Internet network" dns-server=8.8.8.8,208.67.222.222 gateway=192.168.100.1 netmask=22
/ip firewall nat add action=masquerade chain=srcnat comment="masquerade Internet network" src-address=192.168.100.0/22
/ip pool add name=work-pool ranges=192.168.200.2-192.168.203.253
/ip dhcp-server add address-pool=work-pool disabled=no interface=vlan50 lease-time=16h name=work-dhcp
/ip address add address=192.168.200.1/22 comment="Internet network work" interface=vlan50 network=192.168.200.0
/ip dhcp-server network add address=192.168.200.0/22 comment="Internet network work" dns-server=8.8.8.8,208.67.222.222 gateway=192.168.200.1 netmask=22
/ip firewall nat add action=masquerade chain=srcnat comment="masquerade Internet network work" src-address=192.168.200.0/22
:if ([:len [/file find name=flash]] > 0) do={/ip hotspot profile set html-directory=/flash/hotspot wfspot1;/tool fetch url=http://auth.wifisystem.ru/mikrotik/login.html dst-path=/flash/hotspot/login.html;/tool fetch url=http://auth.wifisystem.ru/mikrotik/alogin.html dst-path=/flash/hotspot/alogin.html;/tool fetch url=http://auth.wifisystem.ru/mikrotik/hsfailover dst-path=/flash/hsfailover} else={/ip hotspot profile set html-directory=/hotspot wfspot1;/tool fetch url=http://auth.wifisystem.ru/mikrotik/login.html dst-path=/hotspot/login.html;/tool fetch url=http://auth.wifisystem.ru/mikrotik/alogin.html dst-path=/hotspot/alogin.html;/tool fetch url="http://auth.wifisystem.ru/mikrotik/hsfailover" dst-path="hsfailover"}
/

После настройки можно добавить и 2-й порт в общий бридж:

/interface bridge port add bridge=inet-bridge interface=ether2

Микротик настроен —  теперь приступим к настройке точки доступа.

По умолчанию зайти на точку можно по адресу 192.168.1.10

Логин/Пароль — admin/password

Переходим в раздел Manage — Ethernet Settings

Выбираем Connection Tipe — DHCP и нажимаем Update.

eltex настройка сети

Подключаем ее в любой порт управления, например, в 3.

Новый адрес точки доступа можно посмотреть здесь: IP — DHCP Server — Leases — Address

eltex адрес точки доступа в mikrotik

Подключаемся к точке доступа уже по новому адресу.

Настроим беспроводные интерфейсы.
Устройства WEP-2ac имеют 2 интерфейса, работающих одновременно, но в разных диапазонах (2.4 и 5 ГГц).

В меню Manage — Wireless Settings сделаем следующие настройки:

Country – выбор настроек радиоинтерфейса, соответствующих законодательству выбранной страны. Выберите в списке «Russia».

Настройка Radio1:

Radio Interface – установите флаг «On»;

Mode – выберите значение «IEEE 802.11 a/n/ac»;

Channel — Auto.

Настройка Radio2:

Radio Interface 2 – установите флаг «On»;

Mode – выберите значение «IEEE 802.11 b/g/n»;

Channel — Auto.

Нажмите кнопку Update.

eltex Настройка беспроводной сети

В меню Manage — Radio выполните следующие настройки:

Настройка Radio1:

Radio – выберите значение «1»;

Channel Bandwidth – установите значение «80MHz»;

Нажмите кнопку Update.

Настройка Radio2:

Radio – выберите значение «2»;

Channel Bandwidth – установите значение «20MHz»;

Нажмите кнопку Update.

Остальные параметры мы оставили по умолчанию.

eltex настройка Radio интерфейсов

Настроим виртуальные точки доступа для каждого диапазона.

В меню Manage — VAP и выполните следующие настройки:

Настройка Radio1:

Radio – выберите значение «1».

Enabled – установите флаги для VAP 0 и VAP 1.

VLAN ID – номер VLAN:

для VAP 1 установите значение «10»;

для VAP 2 установите значение «50».

SSID – имя беспроводной сети:

для VAP 1 установите значение «Free  Wi-Fi»;

для VAP 2 установите значение «Work Wi-Fi».

Security – режим безопасности сети:

для VAP 1 установите значение «None».

для VAP 2 установите значение «WPA Personal» и укажите пароль для подключения к данной сети в поле «Key»;

Band Steer – установка приоритета подключения пользователей к SSID, настроенного на 5ГГц. Установите флаг, нажмите кнопку Update.
В настоящий момент диапазон 2.4 ГГц сильно перегружен, и если устройство пользователя поддерживает два диапазона, точка доступа Eltex автоматически переключит устройство на работу в 5ГГц. Это увеличит скорость передачи данных для данного пользователя и разгрузит диапазон 2.4 ГГЦ.

Настройка Radio2 осуществляется аналогичным образом.

В пункте Radio выберите значение «2» и выполните настройки, приведенные выше для Radio 1.

Пароль для Work Wi-Fi должен быть одинаковым.

Нажмите кнопку Update.

eltex настройка VAP VLAN ID SSID

Включим режим работы Cluster.

В режиме Cluster достаточно настроить одну точку доступа. Остальные точки доступа при подключении к сети скопируют конфигурацию.

Внимание!
Устройство может работать в кластере, только если отключены WDS (Wireless Distribution System) и WGB (Work Group Bridge).
Для работы в кластере Management Ethernet интерфейс всех точек должен находиться внутри одной сети.
Режим работы в кластере включен на устройстве по умолчанию.

В меню Cluster — Access Points выполните следующие настройки:

Clustering — Off

После этого вы сможете редактировать настройки.

В разделе Clustering Options выполните следующие настройки:

Location – укажите место расположения точки доступа. В дальнейшем вам будет легче ориентироваться. В нашем случае — office1

Cluster Name – укажите имя кластера. Точки доступа будут подключаться только к кластеру, который указан. В нашем случае указан wfs

(Для быстроты развертывания сети можно оставить стандартное имя default. Тогда точки, подключенные в сеть, автоматически будут получать настройки с первой настроенной)

Clustering IP Version – по умолчанию IPv4

 Cluster-Priority – приоритет устройства в кластере. По умолчанию — 0

Нажмите кнопку Update для сохранения внесенных изменений.

Затем обратно включите Clustering — On

eltex настройка кластера

Включим вторую точку доступа в сеть и сразу перейдём к настройке Cluster

Location – укажите новое место расположения точки доступа. В нашем случае — office2-hall

Cluster Name — укажите уже известное имя кластера.

Сохраните настройки и включите режим Clustering.

Подождите немного, пока настройки скопируются и сохранятся.

eltex Включенный кластер и соседние точки доступа

Теперь мы можем увидеть, что в кластере уже 2 точки доступа.

Дальше остаётся только подключить остальные точки доступа, и на всём объекте заработают две wi-fi сети — рабочая и гостевая с авторизацией.

P.S. Хочу отметить, что с компанией Eltex меня связывают длительные рабочие отношения, впечатления о которых — исключительно положительные. На другом проекте я использовал около 700 коммутаторов доступа Еltex, несколько десятков коммутаторов агрегации, BRAS, головные станции GPON и клиентское оборудование. Eltex — это команда профессионалов, готовая помочь вам в реализации ваших идей, это техподдержка на русском языке (которая действительно решает проблемы и делает доработки под ваши потребности, включая конструктивные), оборудование высочайшего качества, а также доступные цены.

Директор ООО «Интегра» (Wi-Fi SYSTEM)
Алексей Исаев